Something wrong with the OpenVidu

Hello, guys!

I was developing a proof of concept solution, which is pretty simple and mimics behaviour from openvidu-hello-world example, and everything seems to be working just fine, but I am stuck with an issue: for some reason subscribers are not visible in the frontend.

I was trying to launch openvidu-hello-world sample, but it seems that only the publisher video is visible. <video> elements are appended into both #publisher and #subscriber, but I can only see the publisher (local) video.

Another thing is that when I check the console, it throws me these warnings:

Seems that for some reason it fails to fetch the video of the subscribers, and I can’t figure out why, but I have these theories:

  • For some reason, docker build doesn’t work for my ARM macbook, so OpenVidu server that I use is stored in AWS, and it has unsigned https certificate . Could it be the case?
  • I am developing frontend from localhost, so might that be a WebRTC issue?

I feel like I am missing something stupid out, so I would be glad to be put on the road :slight_smile:

  1. I think you’ve configured in your .env in DOMAIN_OR_PUBLIC_IP the public IP. If you’re configuring in your app the EC2 domain name as OPENVIDU_URL it will not work, you need to use the public IP. Otherwise if you configure the EC2 domain name in DOMAIN_OR_PUBLIC_IP you need to configure in the app you’re developing the EC2 domain name in OPENVIDU_URL.
  2. As far as I know iOS and Mac devices needs valid certificates to work with OpenVidu. You may need to install the selfsigned certificate in your computer/iOS devices to make it work, or configure OpenVIdu with a letsencrypt certificate and a FQDN (Fully Qualified Domain Name) assigned to the public IP of OpenVidu.


My suggestions:
Option 1:

  1. Change DOMAIN_OR_PUBLIC_IP to:
  1. Install selfsigned certificate in your iOS/Mac device located at /opt/openvidu/certificates/live/<DOMAIN_OR_PUBLIC_IP>.

Option 2

  1. Purchase a domain and register it to your public IP.
  2. Follow these instructions: OpenVidu Docs

I think the second option it’s better and easier.


Hi, cruizba!

Thank you for the quick response, haven’t even checked this thread till today :smiley:

I’ve tried to fixup all the faulty certificates, but the issue seems to be somewhere else. What I did:

  1. Changed my ec2 URL to a proper subdomain, and installed newest version of OpenVidu with letsencrypt. When I open the subdomain, it works properly, without any warnings.
  2. I downloaded ngrok and used it to proxy to my localhost:8080 where openvidu-hello-world tutorial is stored.

I changed all of the other things accordingly, but the problem still persists. When I run the example in ngrok, I see that <video> elements of subscriber are appended, but no video is visible:

Also, when I try using OpenVidu dashboard to test out the connection it also doesn’t work, and fails with this log: (attached in the next message as I am a new user)

Hope this will provide a clue of what is going on :slight_smile:

Faulty log from the built-in dashboard:

I am so stupid… I checked the other thread with the now resolve guy, and figured out to check whether the ports are opened, and I totally missed out on the UDP part.

Everything seems to be working fine now, thanks for your help!

Will be back here when another challenge appears :slight_smile:

Hahah funny guy: I want to resolve openvidu certificate errors - #6 by cruizba

Now resolve! :wink:

1 Like