Using a mediasoup media node

We have just deployed a new OpenVidu environment in AWS using the cloudformation template latest.
The version reported is 2.19.0. The system is licensed with a Pro license.

We have changed the .env variable OPENVIDU_EDITION to enterprise and ran the restart command.
When we add a new node it still appears to be a Kurento server. (I tried removing all existing nodes and still received Kurento nodes when adding)
After reading the medium article we added the variable OPENVIDU_PRO_MEDIA_SERVER and set its value to mediasoup.
Restarted again and still the same issue.
I guessed that maybe because recording was enabled it was ignoring the setting so I disabled recording but still the same issue persisted.

How do we get OpenVidu to use mediasoup media nodes?

Don’t worry, possibly you’re using mediasoup, just the name of the media nodes still being named as Kurento Media Server.

To check if mediasoup is running, just SSH into one of the Media Nodes machine and execute this:

sudo su
docker ps | grep mediasoup

You should see a container using this image:

openvidu/mediasoup-controller:2.19.0-beta1

Regards

I see, yes when I SSH in I do see the image:


Should I be concerned about the unhealthy status?

I think this is a bug in the health check of the container. I’ll ask @j1elo @micael.gallego

Hello @mvander115,

Please check if sessions are working or not with “unhealthy” in the container.

Maybe it is a false alarm.

FYI I’ve checked the stack and it was working with the unhealthy status.

I can confirm that it is working with the unhealthy status.

False alarm then… we will check it.

Hi, just to confirm, the unhealthy status is already fixed in code and the fix will ship with the next release.

1 Like