Various error building on iOS

I open a new topic becaue I ran into different and new problems trying to build the basic react-native example on iOS.

Step by step:

  • move to “ios” folder and run “pod install”.
  • I received this error: “[!] Invalid Podfile file: no implicit conversion of nil into String”.
  • I fixed it changing in Podfile from this: “use_react_native!(:path => config[“reactNativePath”])” to this “use_react_native!(:path => config[:reactNativePath])”.
  • Run again “pod install”.
  • I received this error:
[!] CocoaPods could not find compatible versions for pod "RCT-Folly":
  In snapshot (Podfile.lock):
    RCT-Folly (from `../node_modules/react-native/third-party-podspecs/RCT-Folly.podspec`)

  In Podfile:
    RCT-Folly (from `../node_modules/react-native/third-party-podspecs/RCT-Folly.podspec`)

It seems like you've changed the version of the dependency `RCT-Folly` and it differs from the version stored in `Pods/Local Podspecs`.
You should run `pod update RCT-Folly --no-repo-update` to apply changes made locally.
  • Run this: “pod update RCT-Folly --no-repo-update”.
  • Run again “pod install” with no errors.
  • Back to main folder and run “npm run ios”.
  • Receive a long error that start with this:
warn Multiple Podfiles were found: ios/Podfile,openvidu-tutorials/openvidu-ionic/ios/App/Podfile,openvidu-tutorials/openvidu-react-native/ios/Podfile. Choosing ios/Podfile automatically. If you would like to select a different one, you can configure it via "project.ios.sourceDir". You can learn more about it here:
info Found Xcode workspace "openvidu_react_native.xcworkspace"
info Building (using "xcodebuild -workspace openvidu_react_native.xcworkspace -configuration Debug -scheme openvidu_react_native -destination id=A2FC2FF6-DDB4-49C6-9FBE-D2C87D260668")
error Failed to build iOS project. We ran "xcodebuild" command but it exited with error code 65. To debug build logs further, consider building your app with, by opening openvidu_react_native.xcworkspace.
Command line invocation:
    /Applications/ -workspace openvidu_react_native.xcworkspace -configuration Debug -scheme openvidu_react_native -destination id=A2FC2FF6-DDB4-49C6-9FBE-D2C87D260668

I’m working on Mac OS Ventura with xCode 14.3.1.

Please, could you help me?