Openvidu-browser 2.16.2


I have noticed that there is a new version 2.16.2 available via npm. Can I safely upgrade to this version when using 2.16.0 on the server side or is there also a new version available? Which commits are included in the version 2.16.2?

Thank you very much!

Hi @adad,

The openvidu-browser 2.16.2 versios is available with the aim of fix bugs and regresions found.
You can use this version with OpenVidu 2.16.0 without a doubt.

You can found the commits included in this version here:



I appreciate all of this but what I need is to get a copy of openvidu-browser-2.16.2.js and openvidu-browser-2.16.2.min.js

I need this to deal with some of the bugs that were in 2.16.0.js and are driving my clients crazy. I’ve been waiting for 2.17.0 but my clients are getting very upset.

I cannot figure out how to get the js files from the git links provided. Can someone please help?


As you know, you can build every single open source artifacts by your own.
Everything is detailed in our docs

Specifically, for openvidu-browser you have to follow these steps

Yes, for getting the compiled JS you just got to:

git clone
cd openvidu/openvidu-browser
npm install
npm run build
VERSION=2.17.0-beta npm run browserify
VERSION=2.17.0-beta npm run browserify-prod

You will get at folder openvidu-browser/static/js/ the compiled js files.


I don’t work with Node.js. But tried to follow instructions and got this error at the npm run build stage (see below). I used yum to install node on Amazon linux 2.



[ec2-user@ip-172-30-0-169 openvidu-browser]$ npm run build

openvidu-browser@2.16.0 build /home/ec2-user/openvidu/openvidu/openvidu-browser
cd src/OpenVidu && ./…/…/node_modules/typescript/bin/tsc && cd …/… && ./node_modules/typescript/bin/tsc --declaration src/index.ts --outDir ./lib --sourceMap --lib dom,es5,es2015.promise,scripthost

var textToKeyword = new ts.Map(ts.getEntries(textToKeywordObj));

TypeError: Iterator value undefined is not an entry object
at new Map (native)
at ts (/home/ec2-user/openvidu/openvidu/openvidu-browser/node_modules/typescript/lib/tsc.js:5975:25)
at Object. (/home/ec2-user/openvidu/openvidu/openvidu-browser/node_modules/typescript/lib/tsc.js:7897:3)
at Module._compile (module.js:577:32)
at Object.Module._extensions…js (module.js:586:10)
at Module.load (module.js:494:32)
at tryModuleLoad (module.js:453:12)
at Function.Module._load (module.js:445:3)
at Module.require (module.js:504:17)
at require (internal/module.js:20:19)

npm ERR! Linux 4.14.203-156.332.amzn2.x86_64
npm ERR! argv “/usr/bin/node” “/usr/bin/npm” “run” “build”
npm ERR! node v6.17.1
npm ERR! npm v3.10.10
npm ERR! openvidu-browser@2.16.0 build: cd src/OpenVidu && ./../../node_modules/typescript/bin/tsc && cd ../.. && ./node_modules/typescript/bin/tsc --declaration src/index.ts --outDir ./lib --sourceMap --lib dom,es5,es2015.promise,scripthost
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the openvidu-browser@2.16.0 build script ‘cd src/OpenVidu && ./…/…/node_modules/typescript/bin/tsc && cd …/… && ./node_modules/typescript/bin/tsc --declaration src/index.ts --outDir ./lib --sourceMap --lib dom,es5,es2015.promise,scripthost’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the openvidu-browser package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! cd src/OpenVidu && ./…/…/node_modules/typescript/bin/tsc && cd …/… && ./node_modules/typescript/bin/tsc --declaration src/index.ts --outDir ./lib --sourceMap --lib dom,es5,es2015.promise,scripthost
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs openvidu-browser
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls openvidu-browser
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/ec2-user/openvidu/openvidu/openvidu-browser/npm-debug.log

I think your Node and NPM versions are too old. Try updating them to the latest LTS.

Thank you. That worked just great!