No connection to OpenVidu Server and 401 Unauthorized

Hi! I am new to WebRTC and trying to build web conferencing web app.
I am running my OpenVidu Server in my Windows computer using Docker.
I also read the Troubleshooting/FAQs section for windows users. I followed the instructions and
I am able to see the OpenVidu dashboard by logging in, ran the test and web cam worked.

Then in my app.js, I followed the insecure-js tutorial on how to use /api/sessions to create session and a confirmation box appeared about “No connection to OpenVidu Server. This may be a certificate error at”. It threw error code: 401 unauthorized. I even pressed OK button and redirected me to
and the only thing I can see was ‘accept-cert’ text and nothing happened.

My web cam shouldn’t be working during testing right?
Here’s my code:

type: “POST”,
url: OPENVIDU_SERVER_URL + “/api/sessions”,
data: JSON.stringify({customSessionId:sessionId}),
header: {
“Authorization”:"Basic " + btoa("OPENVIDUAPP: " + OPENVIDU_SERVER_SECRET),

I’m sorry I’m confused.

Thank you very much.

If you are using Docker for Windows (instead of Docker Toolbox), please start your docker container with this command:

docker run -p 4443:4443 --rm -e OPENVIDU_SECRET=MY_SECRET openvidu/openvidu-server-kms:2.13.0

And let us know it it works.

Hi! I tried the command but unfortunately it won’t let me access the OpenVidu Server Dashboard and the page says localhost refused to connect.

I turned off my firewall but I was not able to access the OpenVidu Server Dashboard.

Thank you very much for the assistance.

Let’s start again.

Do you have Docker Toolbox (based on Virtual box), Docker for Windows or Docker for Mac?

If you are using Docker Toolbox, can you execute the following command?

docker-machine ip default

You have to use the value returned by the command as the OpenVidu IP. It is typically (but can be different).

Can you show us the logs shown when you start openvidu docker container?

Can you show us what happen if you open the url:




i run openVidu with mvn -Dopenvidu.url= package exec:java . but i have Error resolving version for plugin ‘openvidu.url=’ from the repositories [local (C:\Users\Acer.m2\repository), central (]: Plugin not found in any plugin repository on comandline. can you help me, I am very confused about it.

If you do not plan to fork or improve OpenVidu and you just want to use it, please follow the instructions to deploy it dockerized.