WebSocket connect fail

I started openvidu-server-kms using docker in Windows environment.
The address using the REST API was possible using https://<DOMAIN_IP>:4443, but the websocket could not connect.
The websocket address is wss://<DOMAIN_IP>:4443/openvidu.
Do I need to change the websocket address?

You need to provide configuration parameter -e DOMAIN_OR_PUBLIC_IP=DOMAIN_IP

It was specified as a command when running openvidu-server-kms in docker. The command is as below.

→ docker run -p 4443:4443 --rm -e OPENVIDU_SECRET=MY_SECRET -e DOMAIN_OR_PUBLIC_IP= openvidu/openvidu-server-kms

Well, then the websocket will be wss://
If your client can’t connect to it, then there must be some kind of networking problem. For example an invalid certificate that you will need to accept on the browser before connecting.

In fact, the websocket connection works fine in the browser.
What I’m doing is a websocket connection in C#, but I can’t connect in C#.

@pabloFuente he is using the development image in windows. If you are in your development windows machine @seungsun, Probably you need to run the docker image like this:

docker run -p 4443:4443 --rm -e OPENVIDU_SECRET=MY_SECRET openvidu/openvidu-server-kms:2.21.0

Then you need to access to https://localhost:4443

If you want to access to the deployment through your LAN network, you will need to use the in DOMAIN_OR_PUBLIC_IP the IP of your host in your LAN.

For a production deployment you need a Linux Server with docker and docker-compose installed and follow deployment instructions. For OpenVidu CE follow this: On premises - OpenVidu Docs

I ran the docker command you gave me, but I still can’t connect to the websocket.
Maybe firewall blocking it?
Is there a separate websocket port?
Is on-premises not possible in a Windows environment?

I solved it.
It was a TLS problem in C#.
I solved it by adding the corresponding syntax for WebSocket:
socket.SslConfiguration.EnabledSslProtocols = System.Security.Authentication.SslProtocols.Tls12