Recording records Google Chrome page only

Hello. I’m running version 2.12.0 with recording enabled. Docker is deployed ok. Using “recordingMode: ALWAYS”, “outputMode: COMPOSED” and “recordingLayout: BEST_FIT”. When the session starts the recording is initiated. But opening the video this only recorded a Google Chrome screen, see image bellow:

In server logs the URL is correct, no errors.

1 Like

I’m having the same issue. Anyone with a solution?


COMPOSED video recording with OpenVidu 2.12.0 is working perfectly fine in the two deployments currently officially supported by OpenVidu:

Our tests indicate they are fine, and I just tried them out manually from scratch and work as expected. Any detail of your deployment that might be affecting it?

Hi Pablo,

Good news about working, so, i need some help with configuration maybe. Could you help me?

Also, i cant log in Kibana.

Below my deployment parameters and a screenshot from a session video record.

AwsInstanceTypeKMS c5.xlarge -
AwsInstanceTypeOV t2.xlarge -
FreeHTTPAccesToRecordingVideos false -
MediaNodesStartNumber 1 -
MyDomainName -
OpenViduRecordingTimeOut 120 -
OpenViduWebhook false -
OpenViduWebhookEndpoint -
**OpenViduWebhookEvents **sessionCreated,sessionDestroyed,participantJoined,participantLeft,webrtcConnectionCreated,webrtcConnectionDestroyed,recordingStatusChanged,filterEventDispatched,mediaNodeStatusChanged -
OpenViduWebhookHeaders - -
OpenviduCDREnable true -
OpenviduClusterLoadStrategy streams -
OpenviduRecordingNotification publisher_moderator -
OpenviduStreamsVideoMaxRecvBandwidth 1000 -
OpenviduStreamsVideoMaxSendBandwidth 1000 -
OpenviduStreamsVideoMinRecvBandwidth 300 -
OpenviduStreamsVideoMinSendBandwidth 300 -
OwnCertCRT - -
OwnCertKEY - -
**WhichCert **letsencrypt

Best regards.

After deploy this version,, my problem with recording was solved. Before i was using version.

I am also facing the same @micael.gallego not able to connect Kibana and I am tried using tunneling as well still I am not able to

Please @Harishelorce can you open another thread as your problems seems different (connection to Kibana vs failed recording).

We are preparing a new version to be published this 21st of March that will solve installation issues that some of you are facing.

Thank you.

Hello we are also facing the same issue where we get chrome screen in the recording video. We are using openvidu 2.15.0 on premise. Is there a solution for this issue @pabloFuente ?

Please update to a newer version of OpenVidu, in which this issue was solved

Hi @pabloFuente , we are facing the same issue of getting chrome screen in recording video, and we are using openvidu 2.15.0 on premise, we deployed it on two environments. On one we face this issue but on second no such issue is observed and it works fine. Kindly suggest something.