Error while testing Ent v2.20.0

I successfully deployed OV Ent v1.20 on AWS. Everything looks good and I am able to successfully run curl -u OPENVIDUAPP:{SECRET} https://{host}/openvidu/api/config call

When tried to test connection in the inspector I am getting below error in the browser:

Success retrieving OpenVidu Server configuration
main-es2018.2b1445e4e51e0971eae1.js:1 Active sessions info fetched:  Array(0)
main-es2018.2b1445e4e51e0971eae1.js:1 Info websocket connected
main-es2018.2b1445e4e51e0971eae1.js:1 OpenVidu initialized
main-es2018.2b1445e4e51e0971eae1.js:1 Platform detected: Chrome 96.0.4664.93 32-bit on Windows 10 64-bit
main-es2018.2b1445e4e51e0971eae1.js:1 openvidu-browser version: 2.20.0
main-es2018.2b1445e4e51e0971eae1.js:1 STUN/TURN server IP: x.x.x.x.
main-es2018.2b1445e4e51e0971eae1.js:1 TURN temp credentials [OEWCNM:kyaacl]
main-es2018.2b1445e4e51e0971eae1.js:1 openvidu-server version: 2.20.0
main-es2018.2b1445e4e51e0971eae1.js:1 'Connection' created (local)
main-es2018.2b1445e4e51e0971eae1.js:1 Event 'videoElementCreated' triggered by 'Publisher' t {hasBeenPrevented: false, cancelable: false, target: t, type: 'videoElementCreated', element: video#local-video-undefined}
main-es2018.2b1445e4e51e0971eae1.js:1 Event 'accessAllowed' triggered by 'Publisher'
**main-es2018.2b1445e4e51e0971eae1.js:1 ERROR Error: Uncaught (in promise): InvalidAccessError: Failed to execute 'setRemoteDescription' on 'RTCPeerConnection': Failed to set remote answer sdp: The order of m-lines in answer doesn't match order in offer. Rejecting answer.**
Error: Failed to execute 'setRemoteDescription' on 'RTCPeerConnection': Failed to set remote answer sdp: The order of m-lines in answer doesn't match order in offer. Rejecting answer.
    at b (polyfills-es2018.de3cb0427c663acf5c78.js:1)
    at polyfills-es2018.de3cb0427c663acf5c78.js:1
    at main-es2018.2b1445e4e51e0971eae1.js:1
    at l.invoke (polyfills-es2018.de3cb0427c663acf5c78.js:1)
    at Object.onInvoke (main-es2018.2b1445e4e51e0971eae1.js:1)
    at l.invoke (polyfills-es2018.de3cb0427c663acf5c78.js:1)
    at (polyfills-es2018.de3cb0427c663acf5c78.js:1)
    at polyfills-es2018.de3cb0427c663acf5c78.js:1
    at l.invokeTask (polyfills-es2018.de3cb0427c663acf5c78.js:1)
    at Object.onInvokeTask (main-es2018.2b1445e4e51e0971eae1.js:1)

The test of the inspector section does not work with mediasoup (it is a bug which will be fixed on next release 2.21.0).

Can you test with a tutorial pointing to your deployment?

A few more observations:

While trying to test using sample app, I am getting below error:

ERROR: unknown URL https://video-ent.domain/accept-certificate

OpenVidu Server does not have path /accept-certificate mapped

If you are seeing this message as a result of COMPOSED recording, the problem is most likely an issue with the recording URL.
Current recording URL is https://video-ent.domain/accept-certificate
The recording service cannot access the recording layout through this URL.

Out of the box, there was not load balancer rule added to forward traffic to the target group based on /accept-certificate, I added that manually but still same issue.

Moreover, in the .env config file:

  • CERTIFICATE_TYPE was selfsigned, which I changed to owncert
  • OPENVIDU_PRO_CLUSTER_ENVIRONMENT was set to on-prem which I changed to aws
    ** Restarted Master node(s) as mentioned

Still not able to pass through this error.

How did you deployed?

There are two ways to deploy OpenVidu Enterprise:

    1. Only one Master Node / Regular deployment: You just need to deploy OpenVidu PRO as usual and change the variable OPENVIDU_EDITION to OPENVIDU_EDITION=enterprise=enterprise.
    1. Multiple master Node / High availiability deployment: You even have a video tutorial

Are you using option 1 or 2?

I deployed using option 2 (HA).

One master and one media as minimum instance count. I see in your video that you imported cert files, however, I simply used AWS provided cert using wild card, i.e. *

Yes of course, you can use AWS certs. You don’t need to change CERTIFICATE_TYPE nor OPENVIDU_PRO_CLUSTER_ENVIRONMENT. Please keep it as it was by default.

You should be able after deploy to reach https://video-ent.domain/inspector. If that works, just point your app to the URL and use the secret you’ve setup. You don’t need the /accept-certificate path. If you are using a valid certificate you don’t need to accept any certificate. Otherwise you will need to accept it, but you don’t need to visit that path.