AWs deployment stuck on WaitCondition

Every time I try to use cloud formation to deploy openVidu it gets stuck on the WaitCondition and fails. I have followed OpenVidu Docs and have tried several different instance types, but none seem to finish the deployment.

eventually it bombs out to this:

This is from the logs:

What are you using CE or PRO?

What parameters are you using in your CloudFormation?

Which version of OpenVidu are you using?

Aaah… I see what the problem is. Deploy OpenVidu with this as false:

We had some troubles in our infra this weekend.

This should solve your problem


Thank you very much. I will try that this week. I removed the wait and it worked correctly, but this will hopefully solve my issues.

Hi there,

we have the same behaviour when trying to deploy OpenVidu Pro 2.22.0.
We tried to deploy it multiple times through the CloudFormation stack last Friday, yesterday and today and no matter what we change in the stack config, it keeps failing to create the stack in WaitCondition.
I already wrote to the Pro Support mail address yesterday but haven’t received a response yet. My mail also included a Report generated from OpenVidu on the MasterNode instance, but we were only able to connect to the machine through SSH in one of our attempts. In all the other attempts trying to connect to the machines resulted in a connection error. The Media Nodes are not launched at all.
The report suggested that fetching a certificate from letsencrypt failed because the max number of requests per week (5) was reached, but this only occured because i tried it so often. To make sure this is not the root cause of the troubles we tried to launch a stack with our own certificates but that also led to the failure.
The last thing that was logged in the report was the following line:
“Waiting for kibana in ‘’ ‘URL’. This may take some minutes, please be patient…”
The line repeats probably a thousand times or so.

We were not able to generate a new report since then - the SSH connection just keeps dying after authentication.

The Parameters we used are (“|” means we tried different values):

  • AwsInstanceTypeKMS: c5.large
  • AwsInstanceTypeOV: c5.large
  • CoturnInMediaNodes: false
  • ElasticsearchPassword: **
  • ElasticsearchUrl: -
  • ElasticsearchUser: elasticadmin
  • KeyName: [our AWS key]
  • KibanaUrl: -
  • LetsEncryptEmail: - | [our mail adress]
  • MediaNodesStartNumber: 0 | 1
  • MyDomainName: ****.com
  • OpenViduEdition: pro
  • OpenViduLicense: ****
  • OpenViduSecret: ****
  • OpenViduSubnet: [our subnet]
  • OpenViduVPC: [our default vpc]
  • OwnCertCRT: - | [temporary public download link to our own crt file]
  • OwnCertKEY: - | [temporary public download link to our own key file]
  • PublicElasticIP: [our Elastic IP]
  • Recording: none | local | s3
  • S3RecordingsBucketName: - | [our S3 bucket name]
  • WantToDeployDemos: false
  • WhichCert: letsencrypt | owncert

We tried those stack templates: