# Openvidu /dashboard URL return 404

**URL:** <https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638>\
**Category:** Issues developing apps\
**Tags:** v2\
**Created:** [May 1, 2020, 7:46am UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638 "2020-05-01T07:46:24Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shantanu\_Banerjee](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/shantanu_banerjee/32/348_2.png) [@Shantanu\_Banerjee](https://openvidu.discourse.group/u/Shantanu_Banerjee)\
**Post date:** [May 1, 2020, 7:46am UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/1 "2020-05-01T07:46:24Z")

</div>

I have configured Openvidu in AWS and using letsencrypt certificate.  
When I am accessing URL on port 80 it is showing nginx default response page. But other URL like /dashboard /api is showing 404.  
But when I am using below then it is showing dash board on http (not https)  
[http://banesh.tech:5443/dashboard/](http://banesh.tech:5443/dashboard/)

I am followed the guide 2.13 AWS stack deployment.

Is there any help available why I am facing this issue?

---

<div class="post-metadata">

**Author:** ![micael.gallego](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/micael.gallego/32/2_2.png) [@micael.gallego](https://openvidu.discourse.group/u/micael.gallego)\
**Post date:** [May 1, 2020, 9:06am UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/2 "2020-05-01T09:06:11Z")

</div>

What do you get when accessing to [https://banesh.tech/dashboard/](https://banesh.tech/dashboard/) ?

Have you used Cloud Formation? What are the ports you have opened? 5443 shouldn’t be accesible from outside.

---

<div class="post-metadata">

**Author:** ![Shantanu\_Banerjee](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/shantanu_banerjee/32/348_2.png) [@Shantanu\_Banerjee](https://openvidu.discourse.group/u/Shantanu_Banerjee)\
**Post date:** [May 1, 2020, 9:33am UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/3 "2020-05-01T09:33:06Z")

</div>

Hi Micael,

I am getting 404 when accessing [https://banesh.tech/dashboard/](https://banesh.tech/dashboard/). Yes I have used cloud formation.

when I am accessing [http://banesh.tech:5443/dashboard/](http://banesh.tech:5443/dashboard/) then I am able to see dashboard.

below ports configured via cloud formation

 ![image](https://global.discourse-cdn.com/free1/uploads/openvidu/original/1X/cd34205cb75c1d5a77ade553a9cea13377351739.png)

I am not able to understand the exact root cause.

Here is my below steps:

1. I have configured Openvidu via cloud formation
2. Added already exist domain name as hosted zone.
3. Mapped elastic IP with domain name
4. using certbot command to generate ssl certificate

---

<div class="post-metadata">

**Author:** ![micael.gallego](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/micael.gallego/32/2_2.png) [@micael.gallego](https://openvidu.discourse.group/u/micael.gallego)\
**Post date:** [May 1, 2020, 10:04am UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/4 "2020-05-01T10:04:10Z")

</div>

Please can you ssh to your machine and share the content of `opt/openvidu/docker-compose.yml` please?

---

<div class="post-metadata">

**Author:** ![Shantanu\_Banerjee](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/shantanu_banerjee/32/348_2.png) [@Shantanu\_Banerjee](https://openvidu.discourse.group/u/Shantanu_Banerjee)\
**Post date:** [May 1, 2020, 11:56am UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/5 "2020-05-01T11:56:22Z")

</div>

$ cat /opt/openvidu/docker-compose.yml

# ------------------------------------------------------------------------------

# 

# DO NOT MODIFY THIS FILE !!!

# 

# Configuration properties should be specified in .env file

# 

# Application based on OpenVidu should be specified in

# docker-compose.override.yml file

# 

# This docker-compose file coordinates all services of OpenVidu CE Platform.

# 

# This file will be overridden when update OpenVidu Platform

# 

# ------------------------------------------------------------------------------

version: ‘3.1’

services:

```
openvidu-server:
    image: openvidu/openvidu-server:2.13.0
    restart: on-failure
    network_mode: host
    entrypoint: ['/bin/bash', '-c', 'export COTURN_IP=`/usr/local/bin/discover_my_public_ip.sh`; /usr/local/bin/entrypoint.sh']
    volumes:
        - /var/run/docker.sock:/var/run/docker.sock
        - ${OPENVIDU_RECORDING_PATH}:${OPENVIDU_RECORDING_PATH}
        - ${OPENVIDU_RECORDING_CUSTOM_LAYOUT}:${OPENVIDU_RECORDING_CUSTOM_LAYOUT}
        - ${OPENVIDU_CDR_PATH}:${OPENVIDU_CDR_PATH}
    env_file:
        - .env
    environment:
        - SERVER_SSL_ENABLED=false
        - SERVER_PORT=5443
        - KMS_URIS=["ws://localhost:8888/kurento"]
        - COTURN_REDIS_IP=127.0.0.1

kms:
    image: ${KMS_IMAGE:-kurento/kurento-media-server:6.13.1}
    restart: always
    network_mode: host
    ulimits:
      core: -1
    volumes:
        - /opt/openvidu/kms-crashes:/opt/openvidu/kms-crashes
        - ${OPENVIDU_RECORDING_PATH}:${OPENVIDU_RECORDING_PATH}
    environment:
        - KMS_MIN_PORT=40000
        - KMS_MAX_PORT=57000
        - GST_DEBUG=${KMS_DEBUG_LEVEL:-}

redis:
    image: redis:5.0.7
    restart: always
    network_mode: host

coturn:
    image: openvidu/openvidu-coturn:1.0.0
    restart: on-failure
    network_mode: host
    environment:
        - REDIS_IP=127.0.0.1
        - TURN_LISTEN_PORT=3478
        - DB_NAME=0
        - DB_PASSWORD=turn
        - MIN_PORT=57001
        - MAX_PORT=65535

nginx:
    image: openvidu/openvidu-proxy:1.0.0
    restart: on-failure
    network_mode: host
    volumes:
        - ./certificates:/etc/letsencrypt
        - ./owncert:/owncert
        - ${OPENVIDU_RECORDING_CUSTOM_LAYOUT}:/opt/openvidu/custom-layout
    environment:
        - DOMAIN_OR_PUBLIC_IP=${OPENVIDU_DOMAIN_OR_PUBLIC_IP}
        - CERTIFICATE_TYPE=${CERTIFICATE_TYPE}
        - LETSENCRYPT_EMAIL=${LETSENCRYPT_EMAIL}
        - PROXY_MODE=CE
        - WITH_DEMOS=true
```

---

<div class="post-metadata">

**Author:** ![Oscar.Soto](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/oscar.soto/32/292_2.png) [@Oscar.Soto](https://openvidu.discourse.group/u/Oscar.Soto)\
**Post date:** [May 1, 2020, 12:07pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/6 "2020-05-01T12:07:17Z")

</div>

Hi @Shantanu_Banerjee,

Can you share the content of `.env` file in `/opt/openvidu/.env` and you can show me the link to the CloudFormation you’re using?, thanks.

---

<div class="post-metadata">

**Author:** ![Shantanu\_Banerjee](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/shantanu_banerjee/32/348_2.png) [@Shantanu\_Banerjee](https://openvidu.discourse.group/u/Shantanu_Banerjee)\
**Post date:** [May 1, 2020, 12:11pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/7 "2020-05-01T12:11:19Z")

</div>

```
cat .env 
# OpenVidu configuration
# ----------------------
# Documentation: 

# NOTE: This file doesn't need to quote assignment values, like most shells do.
# All values are stored as-is, even if they contain spaces, so don't quote them.

# Domain name. If you do not have one, the public IP of the machine.
# For example: 198.51.100.1, or openvidu.example.com
OPENVIDU_DOMAIN_OR_PUBLIC_IP=banesh.tech

# OpenVidu SECRET used for apps to connect to OpenVidu server and users to access to OpenVidu Dashboard
OPENVIDU_SECRET=MY_SECRET

# Certificate type:
# - selfsigned: Self signed certificate. Not recommended for production use.
# Users will see an ERROR when connected to web page.
# - owncert: Valid certificate purchased in a Internet services company.
# Please put the certificates files inside folder ./owncert
# with names certificate.key and certificate.cert
# - letsencrypt: Generate a new certificate using letsencrypt. Please set the
# required contact email for Let's Encrypt in LETSENCRYPT_EMAIL
# variable.
CERTIFICATE_TYPE=letsencrypt

# If CERTIFICATE_TYPE=letsencrypt, you need to configure a valid email for notifications
LETSENCRYPT_EMAIL=shantanubanerjee75@gmail.com

# Whether to enable recording module or not
OPENVIDU_RECORDING=true

# Openvidu Folder Record used for save the openvidu recording videos. Change it
# with the folder you want to use from your host.
OPENVIDU_RECORDING_PATH=/opt/openvidu/recordings

# System path where OpenVidu Server should look for custom recording layouts
OPENVIDU_RECORDING_CUSTOM_LAYOUT=/opt/openvidu/custom-layout

# if true any client can connect to
# https://OPENVIDU_SERVER_IP:OPENVIDU_PORT/recordings/any_session_file.mp4
# and access any recorded video file. If false this path will be secured with
# OPENVIDU_SECRET param just as OpenVidu Server dashboard at
# https://OPENVIDU_SERVER_IP:OPENVIDU_PORT
# Values: true | false
OPENVIDU_RECORDING_PUBLIC_ACCESS=true

# Which users should receive the recording events in the client side
# (recordingStarted, recordingStopped). Can be all (every user connected to
# the session), publisher_moderator (users with role 'PUBLISHER' or
# 'MODERATOR'), moderator (only users with role 'MODERATOR') or none
# (no user will receive these events)
OPENVIDU_RECORDING_NOTIFICATION=all

# Timeout in seconds for recordings to automatically stop (and the session involved to be closed)
# when conditions are met: a session recording is started but no user is publishing to it or a session
# is being recorded and last user disconnects. If a user publishes within the timeout in either case,
# the automatic stop of the recording is cancelled
# 0 means no timeout
OPENVIDU_RECORDING_AUTOSTOP_TIMEOUT=120

# Maximum video bandwidth sent from clients to OpenVidu Server, in kbps.
# 0 means unconstrained
OPENVIDU_STREAMS_VIDEO_MAX_RECV_BANDWIDTH=1000

# Minimum video bandwidth sent from clients to OpenVidu Server, in kbps.
# 0 means unconstrained
OPENVIDU_STREAMS_VIDEO_MIN_RECV_BANDWIDTH=300

# Maximum video bandwidth sent from OpenVidu Server to clients, in kbps.
# 0 means unconstrained
OPENVIDU_STREAMS_VIDEO_MAX_SEND_BANDWIDTH=1000

# Minimum video bandwidth sent from OpenVidu Server to clients, in kbps.
# 0 means unconstrained
OPENVIDU_STREAMS_VIDEO_MIN_SEND_BANDWIDTH=300

# true to enable OpenVidu Webhook service. false' otherwise
# Values: true | false
OPENVIDU_WEBHOOK=false

# HTTP endpoint where OpenVidu Server will send Webhook HTTP POST messages
# Must be a valid URL: http(s)://ENDPOINT
#OPENVIDU_WEBHOOK_ENDPOINT=

# List of headers that OpenVidu Webhook service will attach to HTTP POST messages
#OPENVIDU_WEBHOOK_HEADERS=

# List of events that will be sent by OpenVidu Webhook service
# Leave blank if all events.
OPENVIDU_WEBHOOK_EVENTS=[sessionCreated,sessionDestroyed,participantJoined,participantLeft,webrtcConnectionCreated,webrtcConnectionDestroyed,recordingStatusChanged,filterEventDispatched,mediaNodeStatusChanged]

# How often the garbage collector of non active sessions runs.
# This helps cleaning up sessions that have been initialized through
# REST API (and maybe tokens have been created for them) but have had no users connected.
# Default to 900s (15 mins). 0 to disable non active sessions garbage collector
OPENVIDU_SESSIONS_GARBAGE_INTERVAL=900

# Minimum time in seconds that a non active session must have been in existence
# for the garbage collector of non active sessions to remove it. Default to 3600s (1 hour).
# If non active sessions garbage collector is disabled
# (property 'OPENVIDU_SESSIONS_GARBAGE_INTERVAL' to 0) this property is ignored
OPENVIDU_SESSIONS_GARBAGE_THRESHOLD=3600

# Call Detail Record enabled
# Whether to enable Call Detail Record or not
# Values: true | false
OPENVIDU_CDR=true

# Path where the cdr log files are hosted
OPENVIDU_CDR_PATH=/opt/openvidu/cdr

# Kurento Media Server image
# --------------------------
# Docker hub kurento media server: 
# Uncomment the next line and define this variable with KMS image that you want use
# KMS_IMAGE=kurento/kurento-media-server-dev:6.13

# Kurento Media Server Level logs
# -------------------------------
# Uncomment the next line and define this variable to change
# the verbosity level of the logs of KMS
# Documentation: 
# KMS_DEBUG_LEVEL=3,Kurento*:4,kms*:4,sdp*:4,webrtc*:4,*rtpendpoint:4,rtp*handler:4,rtpsynchronizer:4,agnosticbin:4

# Openvidu Server Level logs
# --------------------------
# Uncomment the next line and define this variable to change
# the verbosity level of the logs of Openvidu Service
# RECOMENDED VALUES: INFO for normal logs DEBUG for more verbose logs
OV_CE_DEBUG_LEVEL=DEBUG

# Java Options
# --------------------------
# Uncomment the next line and define this to add
# options to java command
# Documentation: 
JAVA_OPTIONS=-Xms2048m -Xmx4096m
```

---

<div class="post-metadata">

**Author:** ![Oscar.Soto](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/oscar.soto/32/292_2.png) [@Oscar.Soto](https://openvidu.discourse.group/u/Oscar.Soto)\
**Post date:** [May 1, 2020, 12:16pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/8 "2020-05-01T12:16:22Z")

</div>

Hi,

mmm i don’t see nothing bad. can you share the NGINX and Openvidu logs. Go to `/opt/openvidu` folder and use `sudo docker-compose logs nginx` for get the NGINX logs and `sudo docker-compose logs openvidu-server` for get the Openvidu logs. And can you share me the services up?, with the command `docker-compose ps`. Thanks

---

<div class="post-metadata">

**Author:** ![Shantanu\_Banerjee](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/shantanu_banerjee/32/348_2.png) [@Shantanu\_Banerjee](https://openvidu.discourse.group/u/Shantanu_Banerjee)\
**Post date:** [May 1, 2020, 12:50pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/9 "2020-05-01T12:50:35Z")

</div>

```
sudo docker-compose logs nginx
Attaching to openvidu_nginx_1
nginx_1 | 2020/05/01 12:37:44 [emerg] 15#15: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:44 [emerg] 15#15: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:44 [emerg] 15#15: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:44 [emerg] 15#15: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:44 [emerg] 15#15: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:44 [emerg] 15#15: still could not bind()
nginx_1 | nginx: [emerg] still could not bind()
nginx_1 | Domain name: banesh.tech
nginx_1 | Certificated: letsencrypt
nginx_1 | Letsencrypt Email: shantanubanerjee75@gmail.com
nginx_1 | Proxy mode: CE
nginx_1 | Demos mode: true
nginx_1 | ===Mode letsencrypt===
nginx_1 | The certificate already exists, using them...
nginx_1 | 2020/05/01 12:37:46 [warn] 34#34: "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | nginx: [warn] "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | 2020/05/01 12:37:46 [warn] 37#37: "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | nginx: [warn] "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx_1 | 2020/05/01 12:37:46 [emerg] 37#37: still could not bind()
nginx_1 | nginx: [emerg] still could not bind()
nginx_1 | Restarting nginx: nginx failed!

sudo docker-compose logs openvidu-server
Attaching to openvidu_openvidu-server_1
openvidu-server_1 | Using java options: -Xms2048m -Xmx4096m
openvidu-server_1 | 
openvidu-server_1 | ______________________________________________
openvidu-server_1 | ______ ___ _       
openvidu-server_1 | / __ \ \ \ / (_) | |      
openvidu-server_1 | | | | |_ _____ _ _\ \ / / _ __| |_ _
openvidu-server_1 | | | | | '_ \ / _ \ '_ \ \/ / | |/ _` | | | |
openvidu-server_1 | | |__| | |_) |__/ | | \ / | | (_| | |_| |
openvidu-server_1 | \ ____/| .__ / \ ___|_| |_|\/ |_|\__ ,_|\__,_|
openvidu-server_1 | | |
openvidu-server_1 | |_| version 2.13.0
openvidu-server_1 | ______________________________________________                                          
openvidu-server_1 | 
openvidu-server_1 | [INFO] 2020-05-01 12:37:45,990 [main] io.openvidu.server.OpenViduServer - Starting OpenViduServer on ip-172-31-28-98 with PID 19 (/openvidu-server.jar started by root in /)
openvidu-server_1 | [INFO] 2020-05-01 12:37:45,993 [main] io.openvidu.server.OpenViduServer - No active profile set, falling back to default profiles: default
openvidu-server_1 | [ERROR] 2020-05-01 12:37:46,154 [main] io.openvidu.server.config.OpenviduConfig - .env file not found at /./.env
openvidu-server_1 | [INFO] 2020-05-01 12:37:46,232 [main] io.openvidu.server.OpenViduServer - Started OpenViduServer in 1.18 seconds (JVM running for 1.898)
openvidu-server_1 | [INFO] 2020-05-01 12:37:46,233 [main] io.openvidu.server.OpenViduServer - 
openvidu-server_1 | 
openvidu-server_1 | 
openvidu-server_1 | Configuration properties
openvidu-server_1 | ------------------------
openvidu-server_1 | 
openvidu-server_1 | * CERTIFICATE_TYPE=letsencrypt
openvidu-server_1 | * OPENVIDU_CDR=true
openvidu-server_1 | * OPENVIDU_CDR_PATH=/opt/openvidu/cdr
openvidu-server_1 | * OPENVIDU_DOMAIN_OR_PUBLIC_IP=banesh.tech
openvidu-server_1 | * OPENVIDU_RECORDING=true
openvidu-server_1 | * OPENVIDU_RECORDING_AUTOSTOP_TIMEOUT=120
openvidu-server_1 | * OPENVIDU_RECORDING_COMPOSED_URL=
openvidu-server_1 | * OPENVIDU_RECORDING_CUSTOM_LAYOUT=/opt/openvidu/custom-layout
openvidu-server_1 | * OPENVIDU_RECORDING_NOTIFICATION=all
openvidu-server_1 | * OPENVIDU_RECORDING_PATH=/opt/openvidu/recordings
openvidu-server_1 | * OPENVIDU_RECORDING_PUBLIC_ACCESS=true
openvidu-server_1 | * OPENVIDU_RECORDING_VERSION=2.9.0
openvidu-server_1 | * OPENVIDU_SECRET=wipro@123
openvidu-server_1 | * OPENVIDU_SESSIONS_GARBAGE_INTERVAL=900
openvidu-server_1 | * OPENVIDU_SESSIONS_GARBAGE_THRESHOLD=3600
openvidu-server_1 | * OPENVIDU_STREAMS_VIDEO_MAX_RECV_BANDWIDTH=1000
openvidu-server_1 | * OPENVIDU_STREAMS_VIDEO_MAX_SEND_BANDWIDTH=1000
openvidu-server_1 | * OPENVIDU_STREAMS_VIDEO_MIN_RECV_BANDWIDTH=300
openvidu-server_1 | * OPENVIDU_STREAMS_VIDEO_MIN_SEND_BANDWIDTH=300
openvidu-server_1 | * OPENVIDU_WEBHOOK=false
openvidu-server_1 | * OPENVIDU_WEBHOOK_ENDPOINT=
openvidu-server_1 | * OPENVIDU_WEBHOOK_EVENTS=[sessionCreated,sessionDestroyed,participantJoined,participantLeft,webrtcConnectionCreated,webrtcConnectionDestroyed,recordingStatusChanged,filterEventDispatched,mediaNodeStatusChanged]
openvidu-server_1 | * OPENVIDU_WEBHOOK_HEADERS=[]
openvidu-server_1 | 
openvidu-server_1 | 
openvidu-server_1 | 
openvidu-server_1 | [INFO] 2020-05-01 12:37:46,233 [main] io.openvidu.server.OpenViduServer - Using /dev/urandom for secure random generation
openvidu-server_1 | [INFO] 2020-05-01 12:37:46,297 [main] io.openvidu.server.OpenViduServer - Starting OpenViduServer on ip-172-31-28-98 with PID 19 (/openvidu-server.jar started by root in /)
openvidu-server_1 | [INFO] 2020-05-01 12:37:46,297 [main] io.openvidu.server.OpenViduServer - No active profile set, falling back to default profiles: default
openvidu-server_1 | [ERROR] 2020-05-01 12:37:47,169 [main] io.openvidu.server.config.OpenviduConfig - .env file not found at /./.env
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,441 [main] org.springframework.boot.web.embedded.tomcat.TomcatWebServer - Tomcat initialized with port(s): 5443 (http)
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,455 [main] org.apache.coyote.http11.Http11NioProtocol - Initializing ProtocolHandler ["http-nio-0.0.0.0-5443"]
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,455 [main] org.apache.catalina.core.StandardService - Starting service [Tomcat]
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,455 [main] org.apache.catalina.core.StandardEngine - Starting Servlet engine: [Apache Tomcat/9.0.30]
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,525 [main] org.apache.catalina.core.ContainerBase.[Tomcat].[localhost].[/] - Initializing Spring embedded WebApplicationContext
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,525 [main] org.springframework.web.context.ContextLoader - Root WebApplicationContext: initialization completed in 1202 ms
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,815 [main] io.openvidu.server.OpenViduServer - OpenVidu CDR service is enabled
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,815 [main] io.openvidu.server.OpenViduServer - OpenVidu Webhook service is disabled (may be enabled with 'OPENVIDU_WEBHOOK=true')
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,824 [main] io.openvidu.server.OpenViduServer - OpenVidu Server using one KMS: ws://localhost:8888/kurento
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,845 [rbeatExec-e1-t0] org.kurento.jsonrpc.client.JsonRpcClientNettyWebSocket - [KurentoClient] Connecting native client
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,847 [rbeatExec-e1-t0] org.kurento.jsonrpc.client.JsonRpcClientNettyWebSocket - [KurentoClient] Creating new NioEventLoopGroup
openvidu-server_1 | [INFO] 2020-05-01 12:37:47,993 [ntLoopGroup-2-1] org.kurento.jsonrpc.client.JsonRpcClientNettyWebSocket - [KurentoClient] Initiating new Netty channel. Will create new handler too!
openvidu-server_1 | [INFO] 2020-05-01 12:37:48,095 [EventExec-e2-t0] io.openvidu.server.kurento.kms.KmsManager - Kurento Client "connected" event for KMS ws://localhost:8888/kurento [org.kurento.client.KurentoClient@370d5142]
openvidu-server_1 | [INFO] 2020-05-01 12:37:48,097 [main] io.openvidu.server.recording.service.RecordingManager - OpenVidu recording service is enabled
openvidu-server_1 | [INFO] 2020-05-01 12:37:48,282 [main] io.openvidu.server.recording.service.RecordingManager - Recording module required: Downloading openvidu/openvidu-recording:2.9.0 Docker image (350MB aprox)
openvidu-server_1 | [INFO] 2020-05-01 12:37:48,866 [main] io.openvidu.server.utils.DockerManager - Docker is installed and enabled
openvidu-server_1 | [INFO] 2020-05-01 12:37:48,866 [main] io.openvidu.server.recording.service.RecordingManager - Initializing recording paths
openvidu-server_1 | [INFO] 2020-05-01 12:37:48,868 [main] io.openvidu.server.recording.service.RecordingManager - OpenVidu Server has write permissions on recording path: /opt/openvidu/recordings
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,443 [main] io.openvidu.server.recording.service.RecordingManager - Kurento Media Server has write permissions on recording path: /opt/openvidu/recordings
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,448 [main] io.openvidu.server.recording.service.RecordingManager - OpenVidu Server has write permissions over files created by Kurento Media Server
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,448 [main] io.openvidu.server.recording.service.RecordingManager - Recording path successfully initialized at /opt/openvidu/recordings
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,567 [main] io.openvidu.server.recording.service.RecordingManager - Docker image already exists locally
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,618 [main] io.openvidu.server.coturn.CoturnCredentialsService - COTURN IP: 3.7.154.191
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,626 [main] io.openvidu.server.coturn.CoturnCredentialsService - COTURN Redis DB accessible with string "ip=127.0.0.1 dbname=0 password=turn connect_timeout=30"
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,626 [main] io.openvidu.server.coturn.CoturnCredentialsService - Cleaning COTURN DB...
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,627 [main] io.openvidu.server.coturn.CoturnCredentialsService - Path of COTURN log files: /var/log/
openvidu-server_1 | [ERROR] 2020-05-01 12:37:49,640 [main] io.openvidu.server.coturn.CoturnCredentialsService - COTURN DB is not empty
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,641 [main] io.openvidu.server.coturn.CoturnCredentialsService - Using COTURN credentials service for BASH environment
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,649 [main] io.openvidu.server.core.SessionManager - Garbage collector for non active sessions initialized. Running every 900 seconds and cleaning up non active Sessions more than 3600 seconds old
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,678 [main] org.springframework.scheduling.concurrent.ThreadPoolTaskScheduler - Initializing ExecutorService 'jsonrpcTaskScheduler'
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,793 [main] org.springframework.scheduling.concurrent.ThreadPoolTaskExecutor - Initializing ExecutorService 'applicationTaskExecutor'
openvidu-server_1 | [INFO] 2020-05-01 12:37:49,884 [main] org.springframework.boot.autoconfigure.web.servlet.WelcomePageHandlerMapping - Adding welcome page: class path resource [static/index.html]
openvidu-server_1 | [INFO] 2020-05-01 12:37:50,079 [main] org.springframework.security.web.DefaultSecurityFilterChain - Creating filter chain: any request, [org.springframework.security.web.context.request.async.WebAsyncManagerIntegrationFilter@69c81773, org.springframework.security.web.context.SecurityContextPersistenceFilter@5f8e8a9d, org.springframework.security.web.header.HeaderWriterFilter@239a307b, org.springframework.web.filter.CorsFilter@61862a7f, org.springframework.security.web.authentication.logout.LogoutFilter@48e1f6c7, org.springframework.security.web.authentication.www.BasicAuthenticationFilter@dc7df28, org.springframework.security.web.savedrequest.RequestCacheAwareFilter@3ad83a66, org.springframework.security.web.servletapi.SecurityContextHolderAwareRequestFilter@6e535154, org.springframework.security.web.authentication.AnonymousAuthenticationFilter@4d14b6c2, org.springframework.security.web.session.SessionManagementFilter@6f204a1a, org.springframework.security.web.access.ExceptionTranslationFilter@7bd7d6d6, org.springframework.security.web.access.intercept.FilterSecurityInterceptor@1c742ed4]
openvidu-server_1 | [INFO] 2020-05-01 12:37:50,118 [main] org.apache.coyote.http11.Http11NioProtocol - Starting ProtocolHandler ["http-nio-0.0.0.0-5443"]
openvidu-server_1 | [INFO] 2020-05-01 12:37:50,136 [main] org.springframework.boot.web.embedded.tomcat.TomcatWebServer - Tomcat started on port(s): 5443 (http) with context path ''
openvidu-server_1 | [INFO] 2020-05-01 12:37:50,137 [main] io.openvidu.server.OpenViduServer - Started OpenViduServer in 3.89 seconds (JVM running for 5.803)
openvidu-server_1 | [INFO] 2020-05-01 12:37:50,138 [main] io.openvidu.server.OpenViduServer - 
openvidu-server_1 | 
openvidu-server_1 | ----------------------------------------------------
openvidu-server_1 | 
openvidu-server_1 | OpenVidu is ready!
openvidu-server_1 | ---------------------------
openvidu-server_1 | 
openvidu-server_1 | * OpenVidu Server: https://banesh.tech/
openvidu-server_1 | 
openvidu-server_1 | * OpenVidu Dashboard: https://banesh.tech/dashboard/
openvidu-server_1 | 
openvidu-server_1 | ----------------------------------------------------
openvidu-server_1 |
```

---

<div class="post-metadata">

**Author:** ![Oscar.Soto](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/oscar.soto/32/292_2.png) [@Oscar.Soto](https://openvidu.discourse.group/u/Oscar.Soto)\
**Post date:** [May 1, 2020, 12:54pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/10 "2020-05-01T12:54:38Z")

</div>

You have install a NGINX in your machine and the Openvidu NGINX can’t live with the one you have installed locally. Please power off your NGINX with `sudo systemctl stop nginx` and exec `./openvidu restart` in the `/opt/openvidu` folder.

---

<div class="post-metadata">

**Author:** ![Shantanu\_Banerjee](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/shantanu_banerjee/32/348_2.png) [@Shantanu\_Banerjee](https://openvidu.discourse.group/u/Shantanu_Banerjee)\
**Post date:** [May 1, 2020, 1:00pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/11 "2020-05-01T13:00:01Z")

</div>

Thanks @Oscar.Soto

But in that case SSL not working. I am getting security alert. But with system installed nginx I am not facing this.

```
sudo docker-compose logs nginx
Attaching to openvidu_nginx_1
nginx_1 | Domain name: banesh.tech
nginx_1 | Certificated: letsencrypt
nginx_1 | Letsencrypt Email: shantanubanerjee75@gmail.com
nginx_1 | Proxy mode: CE
nginx_1 | Demos mode: true
nginx_1 | ===Mode letsencrypt===
nginx_1 | The certificate already exists, using them...
nginx_1 | 2020/05/01 12:57:58 [warn] 39#39: "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | nginx: [warn] "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | 2020/05/01 12:57:59 [warn] 42#42: "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | nginx: [warn] "ssl_stapling" ignored, no OCSP responder URL in the certificate "/etc/letsencrypt/live/banesh.tech/fullchain.pem"
nginx_1 | Restarting nginx: nginx.
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:53 +0000] "GET / HTTP/1.1" 200 771 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 2020/05/01 12:58:53 [warn] 44#44: *3 an upstream response is buffered to a temporary file /var/cache/nginx/proxy_temp/1/00/0000000001 while reading upstream, client: 223.191.51.26, server: banesh.tech, request: "GET /styles.a826808cbbbc50ad2c95.css HTTP/1.1", upstream: "http://127.0.0.1:5442/styles.a826808cbbbc50ad2c95.css", host: "banesh.tech", referrer: "https://banesh.tech/"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:53 +0000] "GET /runtime.689ba4fd6cadb82c1ac2.js HTTP/1.1" 200 1485 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:53 +0000] "GET /polyfills.742dcf827e11f0014779.js HTTP/1.1" 200 71215 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:53 +0000] "GET /scripts.52f411cb3dcf30f6cbe1.js HTTP/1.1" 200 101661 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 2020/05/01 12:58:53 [warn] 44#44: *10 an upstream response is buffered to a temporary file /var/cache/nginx/proxy_temp/2/00/0000000002 while reading upstream, client: 223.191.51.26, server: banesh.tech, request: "GET /main.70e6fb992125c20dc42a.js HTTP/1.1", upstream: "http://127.0.0.1:5442/main.70e6fb992125c20dc42a.js", host: "banesh.tech", referrer: "https://banesh.tech/"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:53 +0000] "GET /styles.a826808cbbbc50ad2c95.css HTTP/1.1" 200 185615 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:53 +0000] "GET /polyfills-es5.04043d3c01917c1850d7.js HTTP/1.1" 200 133707 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:56 +0000] "GET /main.70e6fb992125c20dc42a.js HTTP/1.1" 200 1230794 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:57 +0000] "GET /assets/images/openvidu_logo.png HTTP/1.1" 200 30263 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:57 +0000] "GET /assets/images/openvidu_vert_white_bg_trans_cropped.png HTTP/1.1" 200 22426 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 2020/05/01 12:58:57 [warn] 44#44: *8 an upstream response is buffered to a temporary file /var/cache/nginx/proxy_temp/3/00/0000000003 while reading upstream, client: 223.191.51.26, server: banesh.tech, request: "GET /assets/images/land2_bg.jpg HTTP/1.1", upstream: "http://127.0.0.1:5442/assets/images/land2_bg.jpg", host: "banesh.tech", referrer: "https://banesh.tech/"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:57 +0000] "GET /assets/images/land2_bg.jpg HTTP/1.1" 200 265554 "https://banesh.tech/" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
nginx_1 | 223.191.51.26 - - [01/May/2020:12:58:58 +0000] "GET /favicon.ico HTTP/1.1" 200 5430 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0" "-"
```

---

<div class="post-metadata">

**Author:** ![Oscar.Soto](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/oscar.soto/32/292_2.png) [@Oscar.Soto](https://openvidu.discourse.group/u/Oscar.Soto)\
**Post date:** [May 1, 2020, 1:04pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/12 "2020-05-01T13:04:39Z")

</div>

Well try remove the old certificates with `sudo rm -rf /opt/openvidu/certificates/*` and restart Openvidu `./openvidu restart`

---

<div class="post-metadata">

**Author:** ![Shantanu\_Banerjee](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/shantanu_banerjee/32/348_2.png) [@Shantanu\_Banerjee](https://openvidu.discourse.group/u/Shantanu_Banerjee)\
**Post date:** [May 1, 2020, 1:09pm UTC](https://openvidu.discourse.group/t/openvidu-dashboard-url-return-404/638/13 "2020-05-01T13:09:15Z")

</div>

Thanks you very much @Oscar.Soto @micael.gallego. It is working now.
