# No Internet Environment Openvidu start error

**URL:** <https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023>\
**Category:** Issues developing apps\
**Tags:** v2\
**Created:** [June 14, 2022, 2:48am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023 "2022-06-14T02:48:05Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![seungsun](https://avatars.discourse-cdn.com/v4/letter/s/5f9b8f/32.png) [@seungsun](https://openvidu.discourse.group/u/seungsun)\
**Post date:** [June 14, 2022, 2:48am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/1 "2022-06-14T02:48:05Z")

</div>

If you start openvidu while there is no internet, it fails to start and an error appears.

In the system configuration, a PC is connected to the router through an internal network.  
The error is:  
dig: couldn’t get address for ‘[resolver1.opendns.com](http://resolver1.opendns.com)’: failure  
dig: couldn’t get address for ‘[ns1.google.com](http://ns1.google.com)’: failure  
dig: couldn’t get address for ‘[ns1-1.akamaitech.net](http://ns1-1.akamaitech.net)’: failure  
[/usr/local/bin/discover\_my\_public\_ip.sh] Discovery failed

What’s the problem?  
The same error occurs even if I try to set the DOMAIN\_OR\_PUBLIC\_IP item value in the .env file to 210.111.220.29 and to set the internal IP to 192.168.2.10.

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [June 14, 2022, 9:20am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/2 "2022-06-14T09:20:16Z")

</div>

What do you think is the problem? 😉 There is no internet and OpenVidu defaults are set for common cloud environments.

Try this:

1. Define in your `/opt/openvidu/.env` this environment variables:

```auto
COTURN_IP=<PRIVATE_IP_REACHABLE_BY_CLIENTS>
PROXY_PUBLIC_IP=<PRIVATE_IP_REACHABLE_BY_CLIENTS>
DOMAIN_OR_PUBLIC_IP=<PRIVATE_IP_REACHABLE_BY_CLIENTS>

```

More info on advanced configuration parameters [here](https://docs.openvidu.io/en/2.22.0/reference-docs/openvidu-config/#advanced-parameters-for-openvidu-ce)

---

<div class="post-metadata">

**Author:** ![seungsun](https://avatars.discourse-cdn.com/v4/letter/s/5f9b8f/32.png) [@seungsun](https://openvidu.discourse.group/u/seungsun)\
**Post date:** [June 16, 2022, 6:42am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/3 "2022-06-16T06:42:13Z")

</div>

Thank you Solved.  
It works fine.

---

<div class="post-metadata">

**Author:** ![poojakamra](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@poojakamra](https://openvidu.discourse.group/u/poojakamra)\
**Post date:** [July 22, 2022, 9:14am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/4 "2022-07-22T09:14:29Z")

</div>

One doubt, as of now after deploying openvidu as on-premise solution when i start the service it tries to access - COTURN IP: 14.142.3.154 which i think is public ip.  
If we dont have internet access then what ip we need to set for COTURN.  
Also do we need to install COTURN SERVER on our local machine.  
Please suggest.

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [July 22, 2022, 7:21pm UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/5 "2022-07-22T19:21:30Z")

</div>

What do you mean by “don’t have internet access” ?

I suppose you are talking about some kind of subnet network not reachable through public IP. Try to configure in `COTURN_IP` the private IP of OpenVidu Server in that network.

Regards

---

<div class="post-metadata">

**Author:** ![poojakamra](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@poojakamra](https://openvidu.discourse.group/u/poojakamra)\
**Post date:** [July 25, 2022, 6:59am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/6 "2022-07-25T06:59:55Z")

</div>

Yes, we have subnet network only.  
IP of openvidu server is - 192.168.148.186  
I have made following changes in .env file:  
COTURN\_IP=192.168.148.186  
PROXY\_PUBLIC\_IP=192.168.148.186  
DOMAIN\_OR\_PUBLIC\_IP=192.168.148.186  
But in logs it is coming as “io.openvidu.server.coturn.CoturnCredentialsService - COTURN IP: 14.142.3.154”  
How to configure COTURN\_IP and in which file changes need to be made?  
Could you please help in this?

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [July 26, 2022, 9:39am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/7 "2022-07-26T09:39:55Z")

</div>

You need to add `/opt/openvidu/.env` the parameter `COTURN_IP=192.168,148.186`. Did you deployed following official deployment instructions?

- CE:
  - [Deploy in AWS](https://docs.openvidu.io/en/stable/deployment/ce/aws/)
  - [Deploy on prem](https://docs.openvidu.io/en/stable/deployment/ce/on-premises/)

- PRO:
  - [Deploy in AWS](https://docs.openvidu.io/en/stable/deployment/pro/aws/)
  - [Deploy on Prem](https://docs.openvidu.io/en/stable/deployment/pro/aws/)

- ENTERPRISE regular deployment (Single master node):
  - [Deploy in AWS](https://docs.openvidu.io/en/stable/deployment/enterprise/aws/#regular-deployment)
  - [Deploy on Prem](https://docs.openvidu.io/en/stable/deployment/enterprise/on-premises/)

- ENTERPRISE with High Availability (Multiple master nodes):
  - [Only available in AWS](https://docs.openvidu.io/en/stable/deployment/enterprise/aws/#high-availability-deployment)

---

<div class="post-metadata">

**Author:** ![poojakamra](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@poojakamra](https://openvidu.discourse.group/u/poojakamra)\
**Post date:** [August 8, 2022, 10:24am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/8 "2022-08-08T10:24:53Z")

</div>

> [@cruizba](#):
>
> do you think is the problem? 😉 There is no in

Hi,  
After adding paramter COTURN\_IP=192.168.148.186. its not working. Do i need to seperately install coturn server on my machine?

Please help.

---

<div class="post-metadata">

**Author:** ![DiStefano8472](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/distefano8472/32/1538_2.png) [@DiStefano8472](https://openvidu.discourse.group/u/DiStefano8472)\
**Post date:** [August 10, 2022, 6:41am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/9 "2022-08-10T06:41:44Z")

</div>

Hi,  
what means “not working”?  
Do you want to use OpenVidu only for internal communication inside your local network?

---

<div class="post-metadata">

**Author:** ![poojakamra](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@poojakamra](https://openvidu.discourse.group/u/poojakamra)\
**Post date:** [August 12, 2022, 6:04am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/10 "2022-08-12T06:04:19Z")

</div>

Yes. We want to setup openvidu on our private network only.

---

<div class="post-metadata">

**Author:** ![DiStefano8472](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/distefano8472/32/1538_2.png) [@DiStefano8472](https://openvidu.discourse.group/u/DiStefano8472)\
**Post date:** [August 18, 2022, 10:30am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/11 "2022-08-18T10:30:16Z")

</div>

If you just want to use it inside your private network, a COTURN server should not be necessary. You would need if users behind different NATs or firewalls want to connect to each other. If I turn off our COTURN server and then start a session in our private network - all participants can hear and see each other.  
Because of this I asked you what do you mean with “not working”. Are you only missing audio and video or does the complete connection fail?

---

<div class="post-metadata">

**Author:** ![poojakamra](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@poojakamra](https://openvidu.discourse.group/u/poojakamra)\
**Post date:** [August 22, 2022, 11:28am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/12 "2022-08-22T11:28:52Z")

</div>

We are setting up the environment in our private network but video conference can be done with client who is not in our network. After setting COTURN\_IP=192.168.148.186, openvidu is trying to access COTURN on IP - 14.142.3.154  
[INFO] 2022-08-22 11:26:44,915 [main] io.openvidu.server.coturn.CoturnCredentialsService - COTURN IP: 14.142.3.154.  
Please help to resolve it.

---

<div class="post-metadata">

**Author:** ![DiStefano8472](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/distefano8472/32/1538_2.png) [@DiStefano8472](https://openvidu.discourse.group/u/DiStefano8472)\
**Post date:** [August 22, 2022, 12:29pm UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/13 "2022-08-22T12:29:31Z")

</div>

OK - your OpenVidu server is part of your private network - but the server has no public IP? It only has access to the internet over a proxy or gateway?

In this case it is normal, that external clients can not participate. An external client can’t do anything with your private it. It needs an public IP where to coturn is located or were the coturn ports (mostly 3478 TCP/UDP) are redirected to your local IP.

Change you firewall/gateway settings to foward the coturn ports to your local ip - or install an external coturn server on a host with public ip and add it to the ice-servers list in your openvidu env file. This is described here and it works for me:  
[https://docs.openvidu.io/en/2.22.0/deployment/allow-users-behind-firewalls/](https://docs.openvidu.io/en/2.22.0/deployment/allow-users-behind-firewalls/)

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [August 29, 2022, 5:58pm UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/14 "2022-08-29T17:58:17Z")

</div>

@poojakamra Did you restarted the server? The COTURN\_IP should be if configured in `/opt/openvidu/.env`.

Answer from @DiStefano8472 is also valid, you can setup an external coturn if you have problems.

Regards,  
Carlos.

---

<div class="post-metadata">

**Author:** ![poojakamra](https://avatars.discourse-cdn.com/v4/letter/p/e495f1/32.png) [@poojakamra](https://openvidu.discourse.group/u/poojakamra)\
**Post date:** [September 20, 2022, 11:30am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/15 "2022-09-20T11:30:15Z")

</div>

After configuring COTURN\_IP i have restarted the server.  
But still it is not working.  
Also we dont have any public server for Coturn.  
So stuck with this.

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [September 20, 2022, 1:42pm UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/16 "2022-09-20T13:42:58Z")

</div>

When you say “not working”. What error appears in your browser side? Did you specify a reachable IP for the clients using openvidu at `COTURN_IP` ?

---

<div class="post-metadata">

**Author:** ![rghavipor](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/rghavipor/32/2030_2.png) [@rghavipor](https://openvidu.discourse.group/u/rghavipor)\
**Post date:** [October 10, 2022, 9:33am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/17 "2022-10-10T09:33:57Z")

</div>

> [@cruizba](#):
>
> `COTURN_IP=<PRIVATE_IP_REACHABLE_BY_CLIENTS`

Hello, I have the same problem  
When I want to reset ./openvidu reset and I don’t have internet, this error appears  
i add `COTURN\_IP no error but when i go to [https://192.168.1.106/dashboard](https://192.168.1.106/dashboard)

i got this from browser

```auto
Unable to connect

An error occurred during a connection to 192.168.1.106.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

```

my .env

**my .env**

```auto
# OpenVidu configuration
# ----------------------
# Documentation: https://docs.openvidu.io/en/stable/reference-docs/openvidu-config/

# NOTE: This file doesn't need to quote assignment values, like most shells do.
# All values are stored as-is, even if they contain spaces, so don't quote them.

# Domain name. If you do not have one, the public IP of the machine.
# For example: 198.51.100.1, or openvidu.example.com
DOMAIN_OR_PUBLIC_IP=192.168.1.106
COTURN_IP=192.168.1.106
# OpenVidu SECRET used for apps to connect to OpenVidu server and users to access to OpenVidu Dashboard
OPENVIDU_SECRET=MY_SECRET

# Certificate type:
# - selfsigned: Self signed certificate. Not recommended for production use.
# Users will see an ERROR when connected to web page.
# - owncert: Valid certificate purchased in a Internet services company.
# Please put the certificates files inside folder ./owncert
# with names certificate.key and certificate.cert
# - letsencrypt: Generate a new certificate using letsencrypt. Please set the
# required contact email for Let's Encrypt in LETSENCRYPT_EMAIL
# variable.
CERTIFICATE_TYPE=selfsigned

# If CERTIFICATE_TYPE=letsencrypt, you need to configure a valid email for notifications
LETSENCRYPT_EMAIL=user@example.com

# Proxy configuration
# If you want to change the ports on which openvidu listens, uncomment the following lines

# Allows any request to http://DOMAIN_OR_PUBLIC_IP:HTTP_PORT/ to be automatically
# redirected to https://DOMAIN_OR_PUBLIC_IP:HTTPS_PORT/.
# WARNING: the default port 80 cannot be changed during the first boot
# if you have chosen to deploy with the option CERTIFICATE_TYPE=letsencrypt
# HTTP_PORT=80

# Changes the port of all services exposed by OpenVidu.
# SDKs, REST clients and browsers will have to connect to this port
# HTTPS_PORT=443

```

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [October 10, 2022, 10:03am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/18 "2022-10-10T10:03:20Z")

</div>

The error you have in your browser has nothing to do with OpenVidu itself.

Can you ping your server from the browser machine? Probably that IP is not reachable somehow, or the service is deployed but ports are not correctly opened so the browser machine can’t reach OpenVidu.

---

<div class="post-metadata">

**Author:** ![rghavipor](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/rghavipor/32/2030_2.png) [@rghavipor](https://openvidu.discourse.group/u/rghavipor)\
**Post date:** [October 10, 2022, 11:18am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/19 "2022-10-10T11:18:14Z")

</div>

I deployed openvidu ce on promise in localhost and make FQDN

Ping is fine with [meet.test.org](http://meet.test.org) (ip : 192.168.1.106)

When internet is connected is ok but when i turn off internet and connected to modem and restart openvidu not responding

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [October 10, 2022, 11:35am UTC](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023/20 "2022-10-10T11:35:57Z")

</div>

You should at least be connected in the same LAN as OpenVidu 😅. No internet connection does not mean that you are not connected to at least, a router or a switch which let both machines to be in the same network.

[Next page](https://openvidu.discourse.group/t/no-internet-environment-openvidu-start-error/4023.md?page=2)
