# Deployment without domain

**URL:** <https://openvidu.discourse.group/t/deployment-without-domain/5474>\
**Category:** Announcements\
**Created:** [February 12, 2026, 2:18pm UTC](https://openvidu.discourse.group/t/deployment-without-domain/5474 "2026-02-12T14:18:48Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [February 12, 2026, 2:18pm UTC](https://openvidu.discourse.group/t/deployment-without-domain/5474/1 "2026-02-12T14:18:48Z")

</div>

OpenVidu v3 supports domain-free deployments using `sslip.io`. However, if you recently deployed without a domain and are experiencing a [LetsEncrypt rate-limit](https://letsencrypt.org/docs/rate-limits/#new-certificates-per-registered-domain), this is likely due to an ongoing rate-limiting problem with [sslip.io](http://sslip.io) (see [cunnie/sslip.io#108](https://github.com/cunnie/sslip.io/issues/108)).

Until this is resolved, we recommend using your own domain name instead.

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [February 12, 2026, 3:09pm UTC](https://openvidu.discourse.group/t/deployment-without-domain/5474/3 "2026-02-12T15:09:09Z")

</div>

When `sslip.io` (or any domain) fails to acquire a valid SSL certificate, your browser will display an `ERR_SSL_PROTOCOL_ERROR` when attempting to access the deployment URL.

 ![image](https://global.discourse-cdn.com/free1/uploads/openvidu/original/2X/4/41e25a24143514261ab77f6a1f166bf2dc3eb420.png)

To confirm this is the issue, check the Caddy logs on your Single Node or any Master Node. SSH into the node and run:

```auto
sudo su
docker logs caddy

```

You should see an error similar to this:

```auto
{"level":"error","ts":1770908645.276268,"logger":"tls.obtain","msg":"could not get certificate from issuer","identifier":"openvidu-cjuzkgrx-13-58-233-208.sslip.io","issuer":"acme-v02.api.letsencrypt.org-directory","error":"HTTP 429 urn:ietf:params:acme:error:rateLimited - too many certificates (50000) already issued for \"sslip.io\" in the last 168h0m0s, retry after 2026-02-12 15:04:09 UTC: see https://letsencrypt.org/docs/rate-limits/#new-certificates-per-registered-domain"}
{"level":"error","ts":1770908645.276335,"logger":"tls.obtain","msg":"will retry","error":"[openvidu-cjuzkgrx-13-58-233-208.sslip.io] Obtain: [openvidu-cjuzkgrx-13-58-233-208.sslip.io] creating new order: attempt 1: https://acme-v02.api.letsencrypt.org/acme/new-order: HTTP 429 urn:ietf:params:acme:error:rateLimited - too many certificates (50000) already issued for \"sslip.io\" in the last 168h0m0s, retry after 2026-02-12 15:04:09 UTC: see https://letsencrypt.org/docs/rate-limits/#new-certificates-per-registered-domain (ca=https://acme-v02.api.letsencrypt.org/directory)","attempt":3,"retrying_in":120,"elapsed":187.594160281,"max_duration":2592000}

```

To resolve this, you can either wait for Caddy’s automatic retry to succeed, or restart your node.  
The retry interval is a custom exponential backoff, you can check it [here](https://github.com/caddyserver/certmagic/blob/707ebd945588a33c5db0b48dd243d81019773b6a/async.go#L166-L190)

If the issue persists, configure your deployment with a custom domain instead by modyfing the parameter `DOMAIN_NAME` of…

Single Node:

```plaintext
/opt/openvidu/config/openvidu.env

```

Elastic/HA:

```plaintext
/opt/openvidu/config/cluster/openvidu.env

```

… configure your DNS to point to your IP/Load Balancer and restart with …

```auto
systemctl restart openvidu

```

---

<div class="post-metadata">

**Author:** ![cruizba](https://yyz2.discourse-cdn.com/free1/user_avatar/openvidu.discourse.group/cruizba/32/18_2.png) [@cruizba](https://openvidu.discourse.group/u/cruizba)\
**Post date:** [June 22, 2026, 10:22am UTC](https://openvidu.discourse.group/t/deployment-without-domain/5474/7 "2026-06-22T10:22:21Z")

</div>


