# Issues with deployment

**URL:** https://openvidu.discourse.group/c/openvidu-v2/openvidu-deployment/5.md

[Latest](https://openvidu.discourse.group/latest.md) · [Categories](https://openvidu.discourse.group/categories.md) · [Tags](https://openvidu.discourse.group/tags.md)

---

## [About the Issues with deployment category](https://openvidu.discourse.group/t/about-the-issues-with-deployment-category/13)

<div class="topic-metadata">

**Author:** [@micael.gallego](https://openvidu.discourse.group/u/micael.gallego)\
**Replies:** 0

</div>

Use this category if you have any problem or questions deploying or configuring OpenVidu in AWS, other cloud provider or on premises. Before posting, remember to visit deployment instructions page before posting your qu…

---

## [OVJSESSIONID cookie does not have secure flag set](https://openvidu.discourse.group/t/ovjsessionid-cookie-does-not-have-secure-flag-set/5488)

<div class="topic-metadata">

**Author:** [@Robin\_Sylvester](https://openvidu.discourse.group/u/Robin_Sylvester)\
**Replies:** 2\
**Last updated:** [April 10, 2026, 8:01am UTC](https://openvidu.discourse.group/t/ovjsessionid-cookie-does-not-have-secure-flag-set/5488 "2026-04-10T08:01:42Z")

</div>

There is a TLS cookie (OVJSESSIONID) associated with the URL https://\<openvidu\_server\>/openvidu. But this cookie does not have the secure flag set which leaves this cookie vulnerable to the attackers. So is there any spe…

---

## [Server information disclosure](https://openvidu.discourse.group/t/server-information-disclosure/5490)

<div class="topic-metadata">

**Author:** [@Robin\_Sylvester](https://openvidu.discourse.group/u/Robin_Sylvester)\
**Replies:** 0\
**Last updated:** [April 10, 2026, 6:49am UTC](https://openvidu.discourse.group/t/server-information-disclosure/5490 "2026-04-10T06:49:52Z")

</div>

The server information is disclosed as nginx in the response headers of all Openvidu server related URLs. Is there any way to remove the server information from the response header ?

---

## [Session ID exposed in the token URL](https://openvidu.discourse.group/t/session-id-exposed-in-the-token-url/5489)

<div class="topic-metadata">

**Author:** [@Robin\_Sylvester](https://openvidu.discourse.group/u/Robin_Sylvester)\
**Replies:** 2\
**Last updated:** [April 10, 2026, 5:32am UTC](https://openvidu.discourse.group/t/session-id-exposed-in-the-token-url/5489 "2026-04-10T05:32:21Z")

</div>

When a session is created and token has been sent to the front-end as a response, the token URL contains the session ID in plain text. (https://\<openvidu\_server\>/openvidu?sessionId=&reconnect=true). Sensitive informatio…

---

## [Unstable connections with 3–4 users](https://openvidu.discourse.group/t/unstable-connections-with-3-4-users/5468)

<div class="topic-metadata">

**Author:** [@lua.net](https://openvidu.discourse.group/u/lua.net)\
**Replies:** 1\
**Last updated:** [January 30, 2026, 11:20am UTC](https://openvidu.discourse.group/t/unstable-connections-with-3-4-users/5468 "2026-01-30T11:20:35Z")

</div>

Hi, We are testing OpenVidu during an integration investigation and are experiencing unstable connections. What we see: Session with 3–4 participants Sometimes one or more users temporarily lose audio/video and disap…

---

## [AMIs for AWS Graviton3](https://openvidu.discourse.group/t/amis-for-aws-graviton3/4476)

<div class="topic-metadata">

**Author:** [@mrussiello](https://openvidu.discourse.group/u/mrussiello)\
**Replies:** 5\
**Last updated:** [January 5, 2026, 4:12pm UTC](https://openvidu.discourse.group/t/amis-for-aws-graviton3/4476 "2026-01-05T16:12:45Z")

</div>

AWS has made it’s Graviton 3 processors available at lower cost and possibly higher performance. Can you please make AMIs for future deployments that will support c7g instance types so we can take advantage of these proc…

---

## [Deployment error](https://openvidu.discourse.group/t/deployment-error/2421)

<div class="topic-metadata">

**Author:** [@sajidak](https://openvidu.discourse.group/u/sajidak)\
**Replies:** 2\
**Last updated:** [January 5, 2026, 3:55pm UTC](https://openvidu.discourse.group/t/deployment-error/2421 "2026-01-05T15:55:55Z")

</div>

Deployment Error Looked at other deployment related issues logged, and found none that matched this case. Error message in step OpenViduServer The requested configuration is currently not supported. Please check th…

---

## [WebSocket connection to wss failed](https://openvidu.discourse.group/t/websocket-connection-to-wss-failed/4721)

<div class="topic-metadata">

**Author:** [@poojakamra](https://openvidu.discourse.group/u/poojakamra)\
**Replies:** 5\
**Last updated:** [January 1, 2026, 6:00am UTC](https://openvidu.discourse.group/t/websocket-connection-to-wss-failed/4721 "2026-01-01T06:00:45Z")

</div>

We have setup openvidu in local enviornment. Machine is not accessible from outside for network. So to run video conferencing feature we have created apache web server that is accessible from outside. In this apache serv…

---

## [2.15 - SSL certificate invalid ERR\_SSL\_PROTOCOL\_ERROR](https://openvidu.discourse.group/t/2-15-ssl-certificate-invalid-err-ssl-protocol-error/1526)

<div class="topic-metadata">

**Author:** [@kirobo\_tashehi](https://openvidu.discourse.group/u/kirobo_tashehi)\
**Replies:** 13\
**Last updated:** [October 16, 2025, 6:08am UTC](https://openvidu.discourse.group/t/2-15-ssl-certificate-invalid-err-ssl-protocol-error/1526 "2025-10-16T06:08:51Z")

</div>

The system is extremely buggy. Tried to setup on Ubuntu 18.04. I generated SSL certificate for my main domain and sub-domain using letsencrypt. It’s working. SSL is valid on :80 apache HTTP port but on OpenVid, I set …

---

## [Unable to test openvidu through dashboard](https://openvidu.discourse.group/t/unable-to-test-openvidu-through-dashboard/855)

<div class="topic-metadata">

**Author:** [@Vinit\_ParadoX](https://openvidu.discourse.group/u/Vinit_ParadoX)\
**Replies:** 9\
**Last updated:** [August 26, 2025, 10:35am UTC](https://openvidu.discourse.group/t/unable-to-test-openvidu-through-dashboard/855 "2025-08-26T10:35:44Z")

</div>

I’m getting this error when i try to test it polyfills.(random alphanumeric text).js:1 POST https://OPENVIDUAPP:testing@\<domain.com\>:\<port\>/api/sessions net::ERR\_NAME\_NOT\_RESOLVED I have changed domain and port for pri…

---

## [Intermittent disconnection between OpenVidu Server and Media Node (Kurento)](https://openvidu.discourse.group/t/intermittent-disconnection-between-openvidu-server-and-media-node-kurento/5417)

<div class="topic-metadata">

**Author:** [@william07](https://openvidu.discourse.group/u/william07)\
**Replies:** 1\
**Last updated:** [August 21, 2025, 1:56pm UTC](https://openvidu.discourse.group/t/intermittent-disconnection-between-openvidu-server-and-media-node-kurento/5417 "2025-08-21T13:56:39Z")

</div>

Hello, We recently faced an intermittent issue in our deployment and I’d like to better understand the potential root causes. Setup: 1 VM running OpenVidu Server 2 VMs running Media Node Controller Openvidu v2…

---

## [Session list not showing in inspector](https://openvidu.discourse.group/t/session-list-not-showing-in-inspector/5285)

<div class="topic-metadata">

**Author:** [@sky](https://openvidu.discourse.group/u/sky)\
**Replies:** 1\
**Last updated:** [February 6, 2025, 9:47pm UTC](https://openvidu.discourse.group/t/session-list-not-showing-in-inspector/5285 "2025-02-06T21:47:58Z")

</div>

Recently, when I access the inspector, the session list is missing. F12 shows a HTTP 500 when accessing /openvidu/api/sessions?webRtcStats=true. After 10-20 attempts, the session list is eventually populated. I tried res…

---

## [Disconnected kurento websocket](https://openvidu.discourse.group/t/disconnected-kurento-websocket/5276)

<div class="topic-metadata">

**Author:** [@darush](https://openvidu.discourse.group/u/darush)\
**Replies:** 4\
**Last updated:** [January 21, 2025, 6:39pm UTC](https://openvidu.discourse.group/t/disconnected-kurento-websocket/5276 "2025-01-21T18:39:22Z")

</div>

hello i have on-perimise openvidu 2.29 with 16 gig ram and 16 core cpu and when more than 40 participants join in a session i see this error \[WARN\] 2025-01-20 08:49:02,473 \[SessionHandler-16q3flqqclas80bk8q7oj67u47-e41…

---

## [Upgrade Offline from 2.17 to 2.29](https://openvidu.discourse.group/t/upgrade-offline-from-2-17-to-2-29/5246)

<div class="topic-metadata">

**Author:** [@antonio.petta](https://openvidu.discourse.group/u/antonio.petta)\
**Replies:** 1\
**Last updated:** [December 9, 2024, 10:38am UTC](https://openvidu.discourse.group/t/upgrade-offline-from-2-17-to-2-29/5246 "2024-12-09T10:38:20Z")

</div>

we need support to upgrade a version of openvidu CE from 2.17 to 2.29 in offline mode. Can you kindly tell us the procedure to be done? We obviously have the possibility to download the necessary from another machine o…

---

## [SSL certificate error](https://openvidu.discourse.group/t/ssl-certificate-error/5220)

<div class="topic-metadata">

**Author:** [@seungsun](https://openvidu.discourse.group/u/seungsun)\
**Replies:** 0\
**Last updated:** [November 1, 2024, 6:30am UTC](https://openvidu.discourse.group/t/ssl-certificate-error/5220 "2024-11-01T06:30:12Z")

</div>

I built openvidu using ubtun 20.04. I am using selfsigned SSL certificate. I created a webpage using apahce2 and connected to the openvidu server. When you access the site opened with apache2 from the client, a guidan…

---

## [AWS Deployment Refuse Connection](https://openvidu.discourse.group/t/aws-deployment-refuse-connection/5119)

<div class="topic-metadata">

**Author:** [@bzoro](https://openvidu.discourse.group/u/bzoro)\
**Replies:** 1\
**Last updated:** [June 22, 2024, 12:31pm UTC](https://openvidu.discourse.group/t/aws-deployment-refuse-connection/5119 "2024-06-22T12:31:37Z")

</div>

I’m following this instruction to deploy OpenVidu on AWS: link But when I connect to the OpenViduServerURL it returns This site can’t be reached Error. FYI: This is my parameters Thanks in advance for any help!

---

## [Web component recording won't start](https://openvidu.discourse.group/t/web-component-recording-wont-start/5113)

<div class="topic-metadata">

**Author:** [@marcoalgoretico](https://openvidu.discourse.group/u/marcoalgoretico)\
**Replies:** 0\
**Last updated:** [June 11, 2024, 2:54pm UTC](https://openvidu.discourse.group/t/web-component-recording-wont-start/5113 "2024-06-11T14:54:13Z")

</div>

I’m using openvidu-webcomponent-2.30.0.js with web component. but when i click on “start recording” button nothing happens…and in console i’ve the following error: Any sggestion on this? thanks

---

## [ICE\_SERVERS configuration issue on OpenVidu CE 2.29](https://openvidu.discourse.group/t/ice-servers-configuration-issue-on-openvidu-ce-2-29/5098)

<div class="topic-metadata">

**Author:** [@Felix](https://openvidu.discourse.group/u/Felix)\
**Replies:** 2\
**Last updated:** [May 30, 2024, 3:03am UTC](https://openvidu.discourse.group/t/ice-servers-configuration-issue-on-openvidu-ce-2-29/5098 "2024-05-30T03:03:40Z")

</div>

The WEBRTC ICE SERVERS can be configured in .env as below. OPENVIDU\_WEBRTC\_ICE\_SERVERS=\[“url=turns:example.turn.com:443,staticAuthSecret=secret”\] But I found we only can use turn:example.turn.com:443 not turns. I also…

---

## [How OpenVidu detect the Public IP when offering the default ICE Servers address](https://openvidu.discourse.group/t/how-openvidu-detect-the-public-ip-when-offering-the-default-ice-servers-address/5100)

<div class="topic-metadata">

**Author:** [@Felix](https://openvidu.discourse.group/u/Felix)\
**Replies:** 2\
**Last updated:** [May 30, 2024, 2:55am UTC](https://openvidu.discourse.group/t/how-openvidu-detect-the-public-ip-when-offering-the-default-ice-servers-address/5100 "2024-05-30T02:55:45Z")

</div>

If we don’t configure OPENVIDU\_WEBRTC\_ICE\_SERVERS in .env file, OpenVidu will use it’s own coturn service address. When a webrtc user join room, the server will give the response with the default turn server. For examp…

---

## [Component Communication and Ports for On-Premises Deployment of OpenVidu](https://openvidu.discourse.group/t/component-communication-and-ports-for-on-premises-deployment-of-openvidu/5082)

<div class="topic-metadata">

**Author:** [@msurowiec](https://openvidu.discourse.group/u/msurowiec)\
**Replies:** 2\
**Last updated:** [May 17, 2024, 11:20am UTC](https://openvidu.discourse.group/t/component-communication-and-ports-for-on-premises-deployment-of-openvidu/5082 "2024-05-17T11:20:57Z")

</div>

I am planning to deploy OpenVidu on-premises and need some clarification on the communication between the various components as I need to explain this to our security team. It is not posible to extract this information f…

---

## [KMS event \[IceComponentStateChange\] (publisher) | state: FAILED](https://openvidu.discourse.group/t/kms-event-icecomponentstatechange-publisher-state-failed/4005)

<div class="topic-metadata">

**Author:** [@Salaheddine\_RACHID](https://openvidu.discourse.group/u/Salaheddine_RACHID)\
**Replies:** 4\
**Last updated:** [May 10, 2024, 12:27pm UTC](https://openvidu.discourse.group/t/kms-event-icecomponentstatechange-publisher-state-failed/4005 "2024-05-10T12:27:32Z")

</div>

Hello, After several searches here or elsewhere I still can’t find a solution. This is about OpenVidu deployment =\> On premises - OpenVidu Docs (CERTIFICATE\_TYPE=selfsigned) I followed all the steps, I manage to acce…

---

## [Error: shared-secret-key not found - openvidu-coturn:2.23.0](https://openvidu.discourse.group/t/error-shared-secret-key-not-found-openvidu-coturn-2-23-0/5028)

<div class="topic-metadata">

**Author:** [@gpgp01](https://openvidu.discourse.group/u/gpgp01)\
**Replies:** 3\
**Last updated:** [May 8, 2024, 3:07pm UTC](https://openvidu.discourse.group/t/error-shared-secret-key-not-found-openvidu-coturn-2-23-0/5028 "2024-05-08T15:07:58Z")

</div>

Hello, i recived this error in to log for container coturn (openvidu\_coturn\_1): Error: shared-secret-key not found Error: shared-secret-key not found. Error: shared-secret-key not found. the container not start: op…

---

## [What version of NGINX is included in CE 2.29.0](https://openvidu.discourse.group/t/what-version-of-nginx-is-included-in-ce-2-29-0/5045)

<div class="topic-metadata">

**Author:** [@mrussiello](https://openvidu.discourse.group/u/mrussiello)\
**Replies:** 1\
**Last updated:** [April 4, 2024, 7:46pm UTC](https://openvidu.discourse.group/t/what-version-of-nginx-is-included-in-ce-2-29-0/5045 "2024-04-04T19:46:19Z")

</div>

How can I tell what version of NGINX is installed in the AWS image for 2.29.0 Is this an up-to-date version? We are receiving alerts from vulnerability scanning tools that our domain is using an obsolete version of Ngin…

---

## [CloudFormation of OpenVidu CE fails](https://openvidu.discourse.group/t/cloudformation-of-openvidu-ce-fails/5031)

<div class="topic-metadata">

**Author:** [@ErikW](https://openvidu.discourse.group/u/ErikW)\
**Replies:** 4\
**Last updated:** [April 4, 2024, 7:30pm UTC](https://openvidu.discourse.group/t/cloudformation-of-openvidu-ce-fails/5031 "2024-04-04T19:30:39Z")

</div>

I’m following the docs for an AWS deployment of OpenVidu CE, but the deployment always fails at “CloudFormationLambdaInvoke” with a “CREATE FAILED” status. Unfortunately, I can’t figure out how to see any relevant logs …

---

## [Recordings remain \`started\` forever](https://openvidu.discourse.group/t/recordings-remain-started-forever/5018)

<div class="topic-metadata">

**Author:** [@ameotoko](https://openvidu.discourse.group/u/ameotoko)\
**Replies:** 2\
**Last updated:** [March 23, 2024, 8:21pm UTC](https://openvidu.discourse.group/t/recordings-remain-started-forever/5018 "2024-03-23T20:21:21Z")

</div>

I have a PRO edition 2.28 deployed on AWS EC2, with recordings being stored in S3. Since in our application the sessions happen in a pre-planned manner according to a schedule, and sometimes there can be no sessions for …

---

## [Mkdir /opt/openvidu: read-only file system](https://openvidu.discourse.group/t/mkdir-opt-openvidu-read-only-file-system/837)

<div class="topic-metadata">

**Author:** [@Raphael](https://openvidu.discourse.group/u/Raphael)\
**Replies:** 8\
**Last updated:** [March 22, 2024, 4:47pm UTC](https://openvidu.discourse.group/t/mkdir-opt-openvidu-read-only-file-system/837 "2024-03-22T16:47:33Z")

</div>

Hello, I am deploying Openvidu on premises, when I start it as root with this command : ./openvidu start I get this error : Starting openvidu\_openvidu-server\_1 … Starting openvidu\_kms\_1 … openvidu\_redi…

---

## [Recording Codec Doesn't Changed](https://openvidu.discourse.group/t/recording-codec-doesnt-changed/5024)

<div class="topic-metadata">

**Author:** [@Nizar](https://openvidu.discourse.group/u/Nizar)\
**Replies:** 1\
**Last updated:** [March 22, 2024, 4:43pm UTC](https://openvidu.discourse.group/t/recording-codec-doesnt-changed/5024 "2024-03-22T16:43:56Z")

</div>

Salam Dears, We are using the pro version and inside .env we are using VP9 codec and the generated recording has VP8 codec, so how can we force openvidu to use VP9? below is our .env: # OpenVidu configuration # ------…

---

## [Openvidu Pro/Enteprise License](https://openvidu.discourse.group/t/openvidu-pro-enteprise-license/5019)

<div class="topic-metadata">

**Author:** [@farid](https://openvidu.discourse.group/u/farid)\
**Replies:** 1\
**Last updated:** [March 14, 2024, 10:45am UTC](https://openvidu.discourse.group/t/openvidu-pro-enteprise-license/5019 "2024-03-14T10:45:40Z")

</div>

Hi may i know if 1 license can be used on multiple domain(setup) at a same time?

---

## [Kurento Media server support for s390x rhel/ IBM cloud](https://openvidu.discourse.group/t/kurento-media-server-support-for-s390x-rhel-ibm-cloud/5005)

<div class="topic-metadata">

**Author:** [@Kanchan\_Bisht](https://openvidu.discourse.group/u/Kanchan_Bisht)\
**Replies:** 3\
**Last updated:** [March 5, 2024, 9:35am UTC](https://openvidu.discourse.group/t/kurento-media-server-support-for-s390x-rhel-ibm-cloud/5005 "2024-03-05T09:35:28Z")

</div>

Hi, I have been facing a problem while deploying the KMS on IBM cloud with s390x architecture. The official Kurento docker image isn’t supported on the mentioned server. Image Link : Docker Steps we did. Created KM…

---

## [AWS deploy error - This combination of host and port requires TLS](https://openvidu.discourse.group/t/aws-deploy-error-this-combination-of-host-and-port-requires-tls/4999)

<div class="topic-metadata">

**Author:** [@Jozef\_Sedlak](https://openvidu.discourse.group/u/Jozef_Sedlak)\
**Replies:** 2\
**Last updated:** [March 4, 2024, 4:06pm UTC](https://openvidu.discourse.group/t/aws-deploy-error-this-combination-of-host-and-port-requires-tls/4999 "2024-03-04T16:06:52Z")

</div>

Hi, I am student and I am learning about developing videocall applications. I have tried official examples from openvidu github locally, and I also tried deploying openvidu call on AWS, however I bumped into this issue: …

[Next page](https://openvidu.discourse.group/c/openvidu-v2/openvidu-deployment/5.md?page=1)
